Open XML Package Editor for VS doesn't open .pptx as zip file

Home Forums PresentationML Open XML Package Editor for VS doesn't open .pptx as zip file

This topic contains 2 replies, has 2 voices, and was last updated by  sliu 8 months, 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #3722

    sliu
    Participant

    Hi Eric,

    I have installed Open XML Package Editor for VS before and it worked. But now after several months, I drag .pptx file to VS, it doesn’t open the file in VS, instead it opens the file in PowerPoint. I thought it might be caused by other VS extensions installed later. So I uninstalled some of them and also uninstalled OpenXml Package Editor too. However, when I tried to reinstall OpenXml Package Editor, I got the error from VSIX installer: “This extension is already installed to all applicable products”. I cannot find it in VS extensions. Now my VS can open .pptx, .docx, etc. in MS Office. How can I solve this problem?

    Thanks in advance!!!

    #3770

    Eric White
    Keymaster

    Yes, this has happened to me. My solution:

    Uninstall the Package Editor, Uninstall VS, reinstall VS, reinstall the package editor. AFAIK there is no other solution.

    IIRC, this occurs when you install Office after installing VS on a machine, and Office changes the registry or something in some way that causes this behavior.

    Things like this is why I always have two fully functional development machines running – I can switch to the other machine, and continue working while uninstalling/reinstalling.

    Wish I had a better answer for you, but I’m afraid that this is the only way to deal with this.

    You might be able to do File/Open the PPTX file and it might open using the Package Editor, even if the registry is messed up. It has been a couple of years since I encountered this because I am careful to first install Office, and then install VS, and finally install the Package Editor.

    Cheers, Eric

    #3779

    sliu
    Participant

    Thanks for the tips. I’ll try it.

    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.