softpagebreaks W:LastRenderedPageBreak

Home Forums WordprocessingML softpagebreaks W:LastRenderedPageBreak

This topic contains 2 replies, has 2 voices, and was last updated by  Manu_TR 4 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #4043

    Manu_TR
    Participant

    Hello,

    Is there a workaround to identify missing softpagebreaks(w:lastRenderedPageBreak) in openxml for below scenarios :

    1. when next page starts with an empty paragraph
    2. long sequences of blank lines

    could someone please help!

    Thanks,
    Manu

    #4048

    Eric White
    Keymaster

    Hi Manu,

    This is a big problem in Word. The w:lastRenderedPageBreak tags are not inserted in the right place. You have identified two places, but there are several others. This is a bug in Word, but I am not hopeful of this bug being addressed by Microsoft.

    The only solution to this would be to write a layout engine, which would be a massive undertaking.

    The gist of this is that you cannot rely on the position of the w:lastRenderedPageBreak.

    Best regards, Eric

    #4049

    Manu_TR
    Participant

    Thanks Eric,

    Could you please help me with this one more issue:

    Hyperlink fieldcode

    Or

    http://stackoverflow.com/questions/41374322/openxml-internal-hyperlink-fieldcode

    Regards
    Manu

    • This reply was modified 4 months, 3 weeks ago by  Manu_TR.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.